Salesforce CTI adapter red error message

Red error box appears in Salesforce where the CTI adapter should be

Error: An Adapter for your Call Center was not found or could not be started. Please contact your Salesforce.com administrator to rectify this issue

After installing Flexor CTI for Salesforce, some users may see the error above in red where the Softphone should be. This error means that the CTI adapter DLL has not been installed or properly registered.The user who installed Flexor may not have the proper privileges to register DLLs.

In this case, here are two possible workarounds. The first workaround is to uninstall Flexor and reinstall it making sure you are logged in to the PC as an administrator.

The second is to follow this process (when logged in as a Windows administrator or at least a user who can register DLLs):

Navigate in Windows Explorer to the Flexor program directory C:\Program Files\Camrivox\Flexor Manager\n.n.nn (where n.n.nn is the version of Flexor installed on the PC).
Double click or Right click and select "Open with" on the "SfAdapter.dll" adapter DLL. It'll give you a window saying it doesn't know what to do with it.  Select "select program from list."
In the ensuing window, press Browse.  There, type c:\windows\system32\regsvr32
Turn on the "Always use the selected program" checkbox.  Press OK. You should see a message that the operation succeeded.

After restarting Flexor and the browser if the red error message still appears when logged into Salesforce please send the error message and Flexor install log to support. The Flexor Install log file (InstallLog) is found in: C:\Program Files\Camrivox\Flexor Manager\x.x.x. (where x.x.x. is the current version of Flexor).

Only Firefox 3.5 is supported. An update to support Firefox 3.6 will be available soon.


Copyright © Camrivox 2008.Website Terms of Use Policy - Privacy Policy - Terms & Conditions of Sale