Check Version of Polycom Firmware

Flexor pop up regarding Polycom firmware

Flexor checks your Polycom phone to make sure it is using compatible Firmware, a pop up warning will appear to let you know the Firware needs upgrading.  Other symptoms can be click to dial not working or inbound calls not popping up the call summary window.

Firmware version 3.1.2.0392 or later is required.

To check the Firmware on your Polycom, on the phone front panel press the Menu button then: Status > Platform > Application > Main

To upgrade your Polycom firmware please refer to Polycom documentation at the link above.


Copyright © Camrivox 2008.Website Terms of Use Policy - Privacy Policy - Terms & Conditions of Sale