CTI adapter not responding in Internet Explorer 10 or 11

Description of Problem

The Salesforce CTI adpater appears to load in the browser correctly but does not respond or stops responding during a call.


Symptoms

Summary

The CTI adapter appears in the browser but does not respond as expected during calls.

CTI adapter present in Salesforce 

When logged into Salesforce the CTI adapter appears (as in the screen shot below) and may react as a call is made or received but will at some point stop responding or updating. 


CTI adapter on a call

Salesforce CTI adpater

Check version of Internet Explorer

In Internet Explorer, navigate to Tools, About Internet Explorer.


IE Tools About

Screen shot of IE Tools menu

Browser version compatibility

Since Flexor version 2.1.100 Flexor has included version 4.03 of the Salesforce CTI adapter. This is the latest version of the adapter from Salesforce and supports the widest range of browsers but it does not support Internet Explorer 10 or 11.

This table lists compatibility.

Alternatives

Use one of the other supported browsers Firefox or Chrome (see the compatibility list above).

If you are using Salesforce Enterprise edition or above (or have API access with another edition) switch to using Flexor Apex for Salesforce as this supports the newer versions of IE.


If this does not resolve the issue please review the other Salesforce FAQ's or contact support.

Return to the FAQ index.

Copyright © Camrivox 2014.Website Terms of Use Policy - Privacy Policy - Terms & Conditions of Sale